情報通信機器 運用 保守 管理

ビルトイン Administrator アカウントを使って、…

ビルトイン Administrator アカウントを使って、…

Win10Pro環境のお客様よりご連絡。

『ビルトイン Administrator アカウントを使って、… のメッセージが出て、Edgeが開きません。』

画像の説明

また、画像ファイルを開くと次のメッセージが出て、フォトが起動しません。『このアプリはビルトインadministratorではアクティブ化できません』

画像の説明

確認してみると、ストアアプリ全般が起動しないようです。この問題に関しては以前から知られていますが、解決に至らない場合もあるようなので、この際に整理してみます。

まず、エラーメッセージに”ビルトインAdministrator…”とありますが、ログオンしているのはOSインストール時に作成した管理者ユーザー(Administrators)でありビルトインAdministratorアカウントは無効化された状態で別に存在します。つまり、このメッセージは使用中の管理者ユーザーをビルトインAdministratorアカウントと誤認識していることになります。

試しに別アカウントを作成して、権限をadministratorsやusersに変更しながら確認しますが、ストアアプリは問題なく動作します。やはり現在使用中のアカウントがビルインAdministratorではないにも関わらず、ビルインAdministratorとして誤認識されているようです。

次にOS初期インストール状態の別PCと比較しながら、secpol.mscやregeditによる値を確認します。

secpol.msc:ビルトイン Administrator アカウントのための管理者承認モードを使用する

(初期値:無効)

regedit:HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System

FilterAdministratorToken(初期値:0)

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System
\UIPI\

(初期値:null)

これらの値を変更することで、"ビルトインAdministrator"でストアアプリが動作するようですが、現在の状況は従来から使用している管理者ユーザーがビルトインAdministratorと誤認識されていることですから、本PCでは値を変更しても状況は変わりません。

確認していく中で、初期設定の別PCとはUACの設定が違うことに気が付きました。問題のPCではUACレベルが一番下位になっています。これを標準に設定にして再起動したところ、ストアプリが起動するようになりました。

画像の説明

その後は、再度UACレベルを変更してもストアアプリは起動しますから、一時的ですがレジストリの整合性に問題があったようです。

因みに、以下のレジストリを変更しUACを無効化することで同症状を再現することが出来ますが、あくまで人為的な操作であり通常は設定されません。

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System

EnableLUA(初期値:1)

Win10が最後のWindowsになり、既にそして今後も大きなアップデートを繰り返しながら普及していくのでしょうが、整合性の矛盾などその都度大小の問題が無くなることはなさそうです。

powered by HAIK 7.0.2
based on PukiWiki 1.4.7 License is GPL. HAIK

最新の更新 RSS  Valid XHTML 1.0 Transitional